栏目分类:
子分类:
返回
名师互学网用户登录
快速导航关闭
当前搜索
当前分类
子分类
实用工具
热门搜索
名师互学网 > IT > 软件开发 > 后端开发 > Python

6月6日,HTTP/3 正式发布了!

Python 更新时间: 发布时间: IT归档 最新发布 模块sitemap 名妆网 法律咨询 聚返吧 英语巴士网 伯小乐 网商动力

6月6日,HTTP/3 正式发布了!

 优质资源分享 
学习路线指引(点击解锁)知识定位人群定位
李 Python实战微信订餐小程序 李进阶级本课程是python flask+微信小程序的完美结合,从项目搭建到腾讯云部署上线,打造一个全栈订餐系统。
Python量化交易实战入门级手把手带你打造一个易扩展、更安全、效率更高的量化交易系统

经过了多年的努力,在 6 月 6 号,IETF (互联网工程任务小组) 正式发布了 HTTP/3 的 RFC, 这是超文本传输协议(HTTP)的第三个主要版本,完整的 RFC 超过了 20000 字,非常详细的解释了 HTTP/3。

另外有趣的是,6 月 6 号 也是 World IPv6 Launch 的周年纪念日。

HTTP/3 - RFC 9114

2022 年 6 月发布

HTTP/2 - RFC 9113

RFC 9113 在 2022 年 6 月发布,之前的 RFC 7540 已过时。

HTTP/1.1 - RFC 9112

RFC 9112 在 2022 年 6 月发布,之前的 RFC 7230 已过时。

HTTP/3 大有可为

在作者之前的测试中,搭建了一个包含 css, js 资源的前端站点, 分别使用了 HTTP/1.1, HTTP/2, HTTP/3 协议,使用 Chrome 访问网站,客户端在上海,服务器在旧金山,相隔了 10000 公里。

最后的测试结果如下, HTTP/1.1 平均在 3500 ms, HTTP/2 平均在 2500 ms, 而 HTTP/3 平均在 1300 ms, 可以看到 HTTP/3 带来的性能提升还是很明显的。

根据 Cloudflare 网站提供的报告,目前国内使用的主要版本是 HTTP/2,而 HTTP/3 占小部分。

当然,在 HTTP/3 RFC 的发布之后,HTTP/3 的占用率也会越来越高。

而对于开发者来说,将网站切换到 HTTP/3 也非常简单,大多 web server (nginx, apache) 都提供了 HTTP/3 的支持(目前是实验性状态),只需要进行 HTTP/3 ON 类似的一键配置即可,就可以享受到 HTTP/3 所带来的更快的速度和更好的用户体验。

转载请注明:文章转载自 www.mshxw.com
本文地址:https://www.mshxw.com/it/958612.html
我们一直用心在做
关于我们 文章归档 网站地图 联系我们

版权所有 (c)2021-2022 MSHXW.COM

ICP备案号:晋ICP备2021003244-6号